[New Users] Please note that all new users need to be approved before posting. This process can take up to 24 hours. Thank you for your patience.

Name change coupon not working

SilkwarmSilkwarm
Reactions: 100
Post: 1
Member
in Bug Reporting
Hello,

I purchased a name change coupon, opened it and got the etc item, i tried changing name a couple of times and it told me "You cannot use that name try again with a different one" i assume because it was a taken name.

Having found one that works by checking with a new character, i tried using that one just to find out none are working, none at all. When i input the name and click change, the window disappears leaving my name as is and not using the ticket.

I thought it was some kind of cooldown for having tried so many times but i've waited now 5-6 hours and it's still the same, furthermore the ticket is gonna expire tonight so that would be a total waste of 15k nx.

Is there anything i can do to fix it?

I tried so far:

- Completing quests
- Killing mobs
- Killing bosses
- Waiting several hours with the client off and on
- Restarted my pc
- Contacted nexon, i only received an automated response

Comments

  • AKradianAKradian
    Reactions: 37,300
    Posts: 5,545
    Volunteer Forum Moderator, Private Tester
    edited September 14
    It is good that you contacted Nexon. Hopefully they will refund or restore your name change coupon if they are unable to solve the problem by tonight.
  • JolreusJolreus
    Reactions: 400
    Posts: 3
    Member
    edited September 26
    Did this ever get resolved? I'm having the same problem right now