[New Users] Please note that all new users need to be approved before posting. This process can take up to 24 hours. Thank you for your patience.

[Tynerum] Demon invitation missing

OrcaTeraburningOrcaTeraburning
Reactions: 210
Posts: 2
Member
edited June 14 in Bug Reporting
Last quest I finished was the 4 marks and [Crimsonheart]Guards of the Castle.

Cant talk to Ridley, and no demon invitation quest on left lightbulb. Anyone else?

Comments

  • ooglaoogla
    Reactions: 515
    Posts: 11
    Member
    edited June 15
    Have you checked the bottom of the quest list? There's no level to the invitation so it gets pushed to the bottom (just accepted it on my end)
    Orionium3
  • ArkiumArkium
    Reactions: 100
    Posts: 2
    Member
    edited June 18
    I have multiple friends with the same issue. One is a demon avenger and the other is an Angelic Buster. I completed it fine with my ice/lightning
  • ZephrayZephray
    Reactions: 630
    Posts: 19
    Member
    edited June 19
    I had a friend with a similar issue not too long ago. Try talking to Ridley to leave Tyrnerum and then check the light bulb for the quest. Hopefully that works.
  • CybelleCybelle
    Reactions: 100
    Post: 1
    Member
    edited June 30
    I have the same exact issue as you. I play a Kanna on the Reboot server. Tried changing channels, restarting the game, leaving the castle through Ridley, checking the quest log for any new quests, but nothing works.
  • baptisobaptiso
    Reactions: 100
    Post: 1
    Member
    edited June 30
    I have the exact same problem as well. I've completed all the quests, only to find no other quest appearing.
    After exiting the game/restarting computer, the quests appear in the 'Completed' category of my quest log, but Ridley presents me with the quests again. I've done them every day now, only to find every day they've just reset. So, I've given up for now...
  • GhibleeGhiblee
    Reactions: 2,030
    Posts: 204
    Administrator, Moderator, Nexon
    edited July 17
    Hello,
    Can you please comment with your IGN and world if you still experience this issue?
  • LosrockLosrock
    Reactions: 100
    Post: 1
    Member
    I have the same issue :(
    IGN: LSRK
    Server: Reboot
  • VitohVitoh
    Post: 1
    Member
    I have the same issue on my kanna "Vitolet" in EU Reboot
  • ZenyltonZenylton
    Post: 1
    Member
    Same issue here
    ign: lmesosfarml
    server: reboot NA
  • Bossgun15Bossgun15
    Reactions: 100
    Post: 1
    Member
    Same issue
    IGN:Bossgun20
    server:reboot NA
  • GateOfCuGateOfCu
    Post: 1
    Member
    Same issue
    IGN:GateOfCu
    Server:Reboot Na