[New Users] Please note that all new users need to be approved before posting. This process can take up to 24 hours. Thank you for your patience.
Check out the v.228 On Air: Glimpse of Joy Patch Notes here!
If this is your first visit, be sure to check out the Forums Code of Conduct: https://forums.maplestory.nexon.net/discussion/29556/code-of-conducts

Returned after 10 years just to find lag

ScarrenScarren
Reactions: 210
Post: 1
Member
in Tech Support
Hi guys,

I wonder if anyone could help me.
I used to play MS about 10-15 years ago, when the europe servers didn't exist yet.

Yesterday I installed the game again (via the launcher).
I've noticed a few things since I've been playing again:
- Starting up the game takes forever
- The game runs super laggy
- There's almost no players on any servers an channels

The slow startup doesn't bother me that much, as long as I can play, and it would be nice to see some more players but thats manable too, but the lag is really f****** annoyiong.
I've tried everything, running the game with the lowest graphics options, setting my laptop to gaming mode, closing every other program on my computer, but it just kee.ps lagging, it's horrible.
Whenever I attack a monster, it stays alive for like 2 or 3 secs and still hits me before going down.
Looting is pratically impossible, pickup rate is about one item every 5 secs.
Portals have a huge delay on them too, it takes like 3 secs before the map transfer happens.

From playiong back in the days I remember just being able to keep my "z" key down, walking through items and just looting like crazy.

Is this stuff my laptop of anything I can change or are there more people experiencing this nowadays.

I'd like to get into playing again, but like this it's no fun.

If you guys have any tips or if anybody can help me, please let me know.

Thanks in advance!!!!~
a returning player
Saliziia

Comments

  • SaliziiaSaliziia
    Reactions: 340
    Posts: 16
    Member
    edited March 8
    I have the same exact issue! Have a really capable MSI gaming laptop but in Maple I experience crazy lag when either just entering a map with mobs in the beginning of launching Maple, maps with a lot of people (Flag Race for example) or hunting with more people in a party. And URSUS - that’s the worst! With 8+ people the lag is insane. It seems the graphic effects are just too much, I hear sound but the graphics are frozen and delayed for a while.

    I’ve already updated the PC in every way, make sure other programs are closed but CPU & Memory spikes like crazy with Maple active. Seems it didn’t change, it actually got worse now to play now (with newer technology)...

    Anyone any tips???