[New Users] Please note that all new users need to be approved before posting. This process can take up to 24 hours. Thank you for your patience.

Memory/DLL corruption

AKradianAKradian
Reactions: 19,355
Posts: 2,711
Member
edited January 13 in Bug Reporting

Bug type: Stability


Brief bug summary: The MapleStory client sometimes enters an abnormal state, that can only be cleared by a Full Shutdown of the computer.

More details:
The symptoms of this abnormal state include:
  • Cutscenes get stuck.
  • Harvesting/Mining does not work.
  • Monsters don't display their name and HP bar, even when set to do so.
  • Top-of-the-screen quest progress notices are not displayed (Quest Helper window works fine)
  • Blaze Wizard's Orbital Flames skill does no damage to enemies.
  • Ice/Lightning Mage Frozen Orb skill does no damage to enemies.
  • Kaiser's Wingbeat skill does no damage to enemies.
  • Bowmaster's Arrow Platter arrows do no damage to enemies.
  • Kaiser/AB's Vertical Grapple (and V skill Rope Lift) only works once per map.
  • Evan's Dragon Glide, and Demon Slayer/Avenger glide, and gliding mounts, keep going even after the key is released.
  • Kanna's Bellflower Barrier and Blossom Barrier appear on the map but don't affect the character.
  • Monsters in Monster Life bob in one place.
  • Magnus (any difficulty) flies into an anti-hack rage, raining deadly meteors far denser than usual, OR No meteors appear at all.
  • Continuous damage is sustained even inside Magnus' barrier.
  • The first few lines of chat after starting the game or being silent for a while, are not sent.
    Lines in whisper/party/buddy/guild/alliance chat look to the speaker as if they were sent, but no-one receives them. Lines in "all" chat don't show up even for the speaker. Commands given in chat window (such as "/find") do nothing.
    After a handful of such ignored lines, chat resumes normally, for a while. After a period of silence, it stops working again.
(forumers are encouraged to add symptoms they have observed to the list)

Changing in-game settings, shutting down the MapleStory client, or even re-installing it, does not change anything. The only known cure is a Full Shutdown and restart of the computer, as apparently a Hybrid/Quick Restart preserves whatever it was that got corrupted.
(For Windows 8 users, forumer YourSuperior suggests following the instructions of this website http://www.howtogeek.com/129021/how-to-do-a-full-shutdown-in-windows-8-without-disabling-hybrid-boot to do a full shutdown)

This has been reported on Windows XP, 7, 8, 8.1, and 10.

Steps to reproduce:
Unfortunately, this does not seem to be consistently reproducible :-(
Ivangold

Comments

  • KThxBaiNaoKThxBaiNao
    Reactions: 10,340
    Posts: 293
    Member
    edited September 2016
    Thanks for this @AKradian :)
  • BOOTY2STRONKBOOTY2STRONK
    Reactions: 410
    Posts: 19
    Member
    edited October 2016
    I would like to add that attacks used when Buckshot is in effect while Memory corruption is taking place will also cause you to do no damage to enemies as a Cannon Master.
  • XariappaXariappa
    Reactions: 655
    Posts: 36
    Member
    edited November 2016
    Don't know if it is related, but recently Monster Life can become very sluggish. It takes seconds to populate the list of monsters when going to another farm, and when returning, it can takes 10s of seconds before my monster farm info is updated, including the list of monsters at the bottom (initially completely empty, no row of monsters shown at all), the farm level, the warus and gems, , etc. All the numbers are at 0 and no monsters show. Even the quest for nurturing or playing doesn't complete right away. Started seeing this yesterday, and it is not account specific. I noticed this most recently on XinnoFarm, around 3PM PST. I normally put my computer in sleep mode, rather than shutting it down, to same me time in starting the computer up.
    And I have seen the monsters on my farms stuck in one place too. As recent as about two weeks ago. A full reboot of the computer was needed to resolve that issue.
    I just rebooted my computer so I will see if my farms are now normally responsive again. So far so good.
  • XariappaXariappa
    Reactions: 655
    Posts: 36
    Member
    edited November 2016
    Here is a picture of what I mean. Looks like extreme lag. Reboot of the computer didn't help, neither reboot of my router.
    image
  • RedNorkRedNork
    Reactions: 100
    Posts: 4
    Member
    edited December 2016
    Restarting didn't do anything for me. And now my Kaiser is starting to freeze in place and pressing the jump button is the only thing that seems to release him. It used to be only after a vertical grapple use, which would end in it being unusable afterwards, but now it happens all the time.
    Are there any other possible cures? Or do we just hafta wait?
  • RexaarRexaar
    Reactions: 630
    Posts: 94
    Member
    edited December 2016
    RedNork
    RedNork said:

    Restarting didn't do anything for me. And now my Kaiser is starting to freeze in place and pressing the jump button is the only thing that seems to release him. It used to be only after a vertical grapple use, which would end in it being unusable afterwards, but now it happens all the time.
    Are there any other possible cures? Or do we just hafta wait?
    Did you do a full shutdown, a normal shutdown is very different from a full shutdown?

  • MageOfBattlesMageOfBattles
    Reactions: 975
    Posts: 82
    Member
    edited December 2016
    Night Walker's shadow spark also doesn't work in the abnormal memory state.
  • TemptationTemptation
    Reactions: 1,255
    Posts: 65
    Member
    edited December 2016
    Mercedes Ishtar ring starts to lag and when attacking mobs the character gets dced by gm police. Restarting the client doesn't work, restart pc neither, need to full shutdown the system. Using windows 7.

    Notes: Full shutdown doesn't always work to fix the bug. The character even lags when it is standing still on a map.
    Steps to reproduce: game crash. I restart the client it get this bug. Goes away randomly... For example yesterday I had the bug and today early in the morning I was fine (servers were not lagging) the client crashed my character got bugged. Rebooted the laptop (didn't do a quick restart) and still the same...
  • RexaarRexaar
    Reactions: 630
    Posts: 94
    Member
    edited December 2016
    Temptation

    Mercedes Ishtar ring starts to lag and when attacking mobs the character gets dced by gm police. Restarting the client doesn't work, restart pc neither, need to full shutdown the system. Using windows 7.

    Notes: Full shutdown doesn't always work to fix the bug. The character even lags when it is standing still on a map.
    Steps to reproduce: game crash. I restart the client it get this bug. Goes away randomly... For example yesterday I had the bug and today early in the morning I was fine (servers were not lagging) the client crashed my character got bugged. Rebooted the laptop (didn't do a quick restart) and still the same...
    Wearing durability equipment (equips from RA boxes, drpq equips) causes lag that is very noticeable on attacks with high attack speed (hurricane, rapid fire) due to constantly updating the durability of the equip.
    Lagging and disconnection by GM police is not part of the memory corruption symptoms.
  • ange1DoIIange1DoII
    Reactions: 870
    Posts: 93
    Member
    edited December 2016
    D/C after using 5th job skill from wind archer (hallowing gate)